[sword-devel] Building Python binding to Sword on Windows returns exit code 1

Greg Hellings greg.hellings at gmail.com
Fri May 16 15:14:51 MST 2014

Do you happen to know which of the projects in the solution failed to
build? I didn't try any of them outside of sword, swordswig, buildtest,
installmgr, and diatheke. All of those worked fine, although I did not test
the result of swordswig to see if it executed.

If you're building all of them, that means you're building both sword and
sword_static. On Windows that will not work because sword_static will
produce a "sword.lib" file while sword will produce both "libsword.dll" and
"sword.lib". It works fine to build both at the same time on Linux because
the name collision does not occur. Try building again and build all of the
products /except/ sword_static. The sword.lib that comes out of building
sword should be MUCH smaller than the 54MB because most of the code will be
in libsword.dll instead. I should update the system to generating the
static target on Windows as basically no one will want static linkage on
Windows - it violates too much of how things actually work there.

Thanks for the report, and don't feel bad about time delays. I myself am
about to get a whole host of distractions between now and the Memorial Day
holiday in the US (don't know where you are so you might not celebrate it).
Including visiting family and vacations, so I might be sketchy between now
and the middle of next week.


On Fri, May 16, 2014 at 3:35 PM, R Johnson <
ps16thypresenceisfullnessofjoy at gmail.com> wrote:

> Thank you for your efforts to get the CMake files to work on Windows. I
> really appreciate it.
> Sorry for taking so long to respond. I've been held up recently by
> Internet connection problems, having to learn how to clone the Sword SVN
> repository with Mercurial, having to build Sword's dependencies (of which I
> wasn't aware until you fixed the CMake file to require them on Windows),
> Visual Studio errors, etc.
> I'm now much closer to being able to get the Sword library built, but
> still not quite there yet. 3 of the projects in the VS2010 solution file
> failed to build. I have extracted the error messages out of the output and
> attached them in a file.
> The first two errors are about not being able to open
> '..\Release\sword.lib'. I don't understand why, since a 54 MB file with
> that name was created in my Release directory.
> The third error is the same one that you mentioned in your 'gcc 4.9.0'
> thread (see my post there). This shows that, as you guessed, the error is
> indeed a problem with SWIG, and not with GCC.
> Thank you for your help.
> -- Timothy
> _______________________________________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel
> Instructions to unsubscribe/change your settings at above page
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.crosswire.org/pipermail/sword-devel/attachments/20140516/29a220eb/attachment-0001.html>

More information about the sword-devel mailing list