[sword-devel] Problem with imp2ld.exe

dmsmith555 at yahoo.com dmsmith555 at yahoo.com
Fri Mar 18 10:46:48 MST 2005

In an earlier note from Chris on the subject of Naves (2/18/2005) he 
notes that mod2imp is broken. So if that is how you got the module in 
order to import it with imp2ld, it may be causing the problem.

Here is what Chris said in that note:
The suggestion to use mod2imp was correct, but isn't going to work. 
There's a bug somewhere in the sorting algorithm, I think, that is 
getting caught on the lowercase of "MINISTER, Civil" and causing the 
library to think it is its own next entry. I think this bug is causing 
what Paul identifies as a problem in ld2imp, which is probably not in 
need of any attention.

Pham, Khoi wrote:

>Thank you
>-----Original Message-----
>From: sword-devel-bounces at crosswire.org
>[mailto:sword-devel-bounces at crosswire.org] On Behalf Of Joachim Ansorg
>Sent: Friday, March 18, 2005 9:08 AM
>To: SWORD Developers' Collaboration Forum
>Subject: Re: [sword-devel] Problem with imp2ld.exe
>>Config file pointed to the right directory.  However, imp2ld.exe
>>the file in the same directory where you run the command.  Here is the
>>text file test.txt I created for testing imp2ld.
>>In Dos prompt, I ran: imp2ld test.txt Strongs.  I got the following
>>response on the screen:
>If you just run "imp2ld" it prints out the options:
>   imp2ld <filename> [modname] [ 4 (default) | 2 | z - module driver]
>Have you tried to run  
> imp2ld test.txt Strongs 2
>or to adjust the ModDrv option if you use the default (4) with imp2ld:
> ModDrv=RawLD4

More information about the sword-devel mailing list