[sword-devel] Re: Problem compiling CVS of Sword

Troy A. Griffitts sword-devel@crosswire.org
Mon, 28 Oct 2002 16:45:20 -0700

SWLog compile error should be fixed.  Don't know why your account had 
troubles checking out.  Please repost if you continue to have troubles 
and feel it is CrossWire's server and not your box.

Thanks for reporting the problem!


Steven P. Ulrick wrote:
>>On Mon, 28 Oct 2002 09:02:46 -0600
>>Steven P. Ulrick <spu@faith4miracle.org> wrote:
>>>Hello, Everyone :)
>>>While trying to compile the CVS of Sword this morning, I got the
>>>following error:
>>>[root@localhost sword]# make
>>>make  all-recursive
>>>make[1]: Entering directory `/home/steve/CVS/sword'
>>>Making all in lib
>>>make[2]: Entering directory `/home/steve/CVS/sword/lib'
>>>source='../src/modules/filters/thmlosis.cpp' object='thmlosis.lo'
>>>libtool=yes \
>>>depfile='.deps/thmlosis.Plo' tmpdepfile='.deps/thmlosis.TPlo' \
>>>depmode=gcc3 /bin/sh ../depcomp \
>>>/bin/sh ../libtool --mode=compile g++ -DUSE_AUTOTOOLS   -DUNIX  -I.
>>>-I.-I.. -I../include  -DUSBINARY  -g -O0 -Werror -c -o thmlosis.lo
>>>`test -f'../src/modules/filters/thmlosis.cpp' || echo
>>>g++ -DUSE_AUTOTOOLS -DUNIX -I. -I. -I.. -I../include -DUSBINARY -g -O0
>>>-Werror -c ../src/modules/filters/thmlosis.cpp -MT thmlosis.lo -MD -MP
>>>-MF .deps/thmlosis.TPlo
>>>../src/modules/filters/thmlosis.cpp: In member function `virtual char
>>>   sword::ThMLOSIS::ProcessText(char*, int, const sword::SWKey*, const
>>>   sword::SWModule*)':
>>>../src/modules/filters/thmlosis.cpp:224: `SWLog' undeclared (first use
>>>   function)
>>>../src/modules/filters/thmlosis.cpp:224: (Each undeclared identifier
>>>   reported only once for each function it appears in.)
>>>../src/modules/filters/thmlosis.cpp:224: parse error before `::' token
>>>make[2]: *** [thmlosis.lo] Error 1
>>>make[2]: Leaving directory `/home/steve/CVS/sword/lib'
>>>make[1]: *** [all-recursive] Error 1
>>>make[1]: Leaving directory `/home/steve/CVS/sword'
>>>make: *** [all] Error 2
>>>When I attempt to grab a fresh copy, logged in as a regular user, I
>>>get the following error:
>>>[steve@localhost steve]$ export
>>>[steve@localhost steve]$ cvs login
>>>Logging in to
>>>CVS password:
>>>[steve@localhost steve]$ cvs checkout sword
>>>cvs checkout: in directory .:
>>>cvs [checkout aborted]: *PANIC* administration files missing
>>>[steve@localhost steve]$
>>>Usually I have no problem getting a fresh copy of the CVS when I am
>>>logged in as myself.  As an experiment, I su'd into root and tried it,
>>>and it worked fine.  Then I went back and tried it again logged into
>>>my user account (a few minutes after my initial success su'd as root)
>>>and I got the same result.  By the way, the grab I started as root is
>>>still coming in, so that issue with the error in my user account is a
>>>mystery to me.
>>>I am running Red Hat 8, with all of the offical updates, including the
>>>kernel, installed.  And of course Red Hat 8 runs gcc 3.2.
> Hello again :)
> Just finished attempting to compile a fresh copy of the CVS of Sword,
> and I had the same result.  The wierd part is that this time, though I
> got the same error, it took a lot longer to occur.  The time that is
> reflected in the error I sent with my initial report was just a minute
> or two, this time it ran about ten minutes or so.
> Steven P. Ulrick