[jsword-devel] Re: Greetings and a couple of questions

Joe Walker jsword-devel@crosswire.org
Tue, 02 Dec 2003 18:27:58 +0000

Did you build using ant first?

When you first check files out of CVS you should run ant using the all 
target to generate required source files from the OSIS XML Schema. These 
are required for most IDEs.

You could probably shorten things a bit using the swingui task I think.

The OSIS classes are generated using JAXB from the x-schema document, 
and the config.xml file (from which the config system works) is 
"compiled" to a .java file, which won't compile if you've got your 
config.xml wrong.


Darren Remington wrote:
>>Date: Sun, 30 Nov 2003 21:55:54 +0000
>>From: Joe Walker <joe@eireneh.com>
>>To: jsword-devel@crosswire.org
>>Subject: Re: [jsword-devel] Greetings and a couple of questions
>>Reply-To: jsword-devel@crosswire.org
>>Darren Remington wrote:
>>>Well, there's the first problem that I've got to overcome - getting the
>>>correct project file. I downloaded jsword-0.9.6-linux-novm.bin from the
>>>JSword download page: http://www.crosswire.org/jsword/download.jsp
>> > What files do I need to download to set up a development directory for
>> > JSword and where do I find them?
>>You've downloaded a binary install so there are no development files 
>>there at all.
>>The best way to get started would be to get the latest CVS copy of 
>>JSword using:
>>   http://www.crosswire.org/jsword/cvs.html
>>Either that or one of the source nightlies.
> I tried a couple of different things, including doing a checkout from
> CVS.
> I first did a download of the source 0.9.6 tarball and unpacked it into
> my Eclipse workspace. The project imported fine, except 2 errors:
> =================================================================
> 1. Project jsword is missing required library:
> 'jsword/target/gener/jsword-osis.jar'.
> 2. Project jsword is missing required source folder:
> 'target/gener/config'.
> =================================================================
> When I tried using the 0.9.5 tarball and the CVS source tree, I got the
> same results.
> One of the build properties is off somewhere. I can't find any
> jsword-osis.jar file anywhere in the source tree.
> Any thoughts?
> Thanks again,
> _______________________________________________
> jsword-devel mailing list
> jsword-devel@crosswire.org
> http://www.crosswire.org/mailman/listinfo/jsword-devel