[xiphos-devel] windows script can't find cmake?

Greg Hellings greg.hellings at gmail.com
Sun May 17 09:08:15 MST 2020

Have you executed the podman build step, per the new docs? The install is
all done during the build step and saved as an image so you don't have to
go through that download and install of the deps on every build.

For me it cuts the build time from about ten minutes to one minute, but
without the build step you'll be missing the needed commands.

On Sun, May 17, 2020, 07:05 Karl Kleinpaste <karl at kleinpaste.org> wrote:

> I've built before for Windows using podman and had no trouble.  Today it
> can't find cmake:
> + echo '** Building Xiphos for Windows-64 bit:'
> ** Building Xiphos for Windows-64 bit:
> + do_build 64
> + bits=64
> + mkdir -p win64
> + cd win64
> + cmake -DCMAKE_TOOLCHAIN_FILE=/usr/share/mingw/toolchain-mingw64.cmake
> -DGTK2=ON /source/xiphos
> */source/xiphos/win32/xc-xiphos-win.sh: line 84: cmake: command not found*
> I wondered if recent changes to how the container is managed had some bad
> effect, so I wiped out ~/.local/share/containers to start fresh and tried
> again; same result.
> I'm trying to do a console-enabled build for someone having trouble on his
> Win64 machine.  Any wisdom available?
> _______________________________________________
> xiphos-devel mailing list
> xiphos-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/xiphos-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.crosswire.org/pipermail/xiphos-devel/attachments/20200517/6878e1bc/attachment.html>

More information about the xiphos-devel mailing list