[xiphos-devel] windows script can't find cmake?

Karl Kleinpaste karl at kleinpaste.org
Sun May 17 05:05:20 MST 2020

I've built before for Windows using podman and had no trouble.  Today it
can't find cmake:

+ echo '** Building Xiphos for Windows-64 bit:'
** Building Xiphos for Windows-64 bit:
+ do_build 64
+ bits=64
+ mkdir -p win64
+ cd win64
+ cmake -DCMAKE_TOOLCHAIN_FILE=/usr/share/mingw/toolchain-mingw64.cmake
-DGTK2=ON /source/xiphos
*/source/xiphos/win32/xc-xiphos-win.sh: line 84: cmake: command not found*

I wondered if recent changes to how the container is managed had some
bad effect, so I wiped out ~/.local/share/containers to start fresh and
tried again; same result.

I'm trying to do a console-enabled build for someone having trouble on
his Win64 machine.  Any wisdom available?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.crosswire.org/pipermail/xiphos-devel/attachments/20200517/0f3e94a0/attachment.html>

More information about the xiphos-devel mailing list