[sword-devel] Not user-friendly behavior in commentaries (should be continuous)

yvand yvand.sword at gmail.com
Thu Jul 23 12:44:41 EDT 2020

Thanks Greg for your quick reply with explanation!

I thought there was a bug and "link entries" were not taken into 
consideration, when using osis2mod. Is there a simple way to test if a 
commentary module contains link entries? I tried with mod2imp to export 
FreCJE but it only shows verses with attached commentary ($$$Genesis 1:2 
is missing for instance). Maybe I misunderstood "link entries" 

I believe it worked as expected in the past (at least with Xiphos), but 
maybe I am wrong.

Unfortunately I am not familiar with C/C++ and with the sword engine, so 
I am not able to offer you a patch.

I understand the issues you pointed and it doesn't seem easy. Currently, 
there are still questions, for instance: how will operate the engine if 
there are multiple commentaries starting with Gen.1.1 in the source, like :

> <div ... annotateRef="Gen.1.1">...</div>
> <div ... annotateRef="Gen.1.1-Gen.1.16">...</div>
> <div ... annotateRef="Gen.1.1-Gen.1.31">...</div>
I guess I will now give up for this feature.


More information about the sword-devel mailing list