[sword-devel] Setting the locale manager bug?

David Haslam dfhmch at googlemail.com
Thu Feb 5 09:10:20 MST 2015

I have Xiphos 4.0.0 installed.

As a newcomer to how these two utilities work, I just tried this in Windows

C:\Users\David\AppData\Roaming\Sword>xiphos\vs2osisreftxt SEN.1.1 pon

So that one seems to work.

btw. What does parameter 3 mean? [test-in-set-verse]

NB. Currently, I have only two locale files in my PC. (pon = Pohnpeian, iu=

However, when I tried this, 

with or without any parameters, I get a Windows Application Error popup

"The application was unable to start correctly (0xc00000005). Click OK to
close the application."

So this utility as compiled for Windows seems to need some attention by the
Xiphos developers,
unless it's due to something else that I don't know about.

On the other hand, this did work:

C:\Users\David\AppData\Roaming\Sword>utils\vs2osisref SEN.1.1 Gen.1.1 pon
<reference osisRef="Gen.1.1">SEN.1.1</reference>

Notes: Windows supports symbolic links (using mklink)

xiphos is a symbolic link to the folder containing xiphos.exe and all the
stuff that installed with it.

utils is a symbolic link to the folder where I downloaded the Sword utils
dated 2013-10-09 
after Greg had compiled them. cf. osis2mod.exe in this set of files was
$Rev: 2893 $


View this message in context: http://sword-dev.350566.n4.nabble.com/Setting-the-locale-manager-bug-tp4654565p4654569.html
Sent from the SWORD Dev mailing list archive at Nabble.com.

More information about the sword-devel mailing list