[sword-devel] FirefoxOS bible app

Matej Cepl mcepl at redhat.com
Thu Dec 26 16:34:00 MST 2013

On Thu, Dec 19, 2013 at 10:38:41AM +0700, Stephan wrote:
>see my note above. If you want to run it on your Peak or in the 
>simulator you have to clone the git repo and point the App 
>Manager to manifest.webwepp (for the debug version) or run sh 
>buildApp.sh and point to manifest.webapp in the 
>deploy/biblez-ng/ folder for the production and minified 
>version. That will fine in the simulator and on a FxOS device 
>(it runs well on my Keon with 1.1 or 1.3).

Yes, as a packaged app it works! Yuhoooo! Which means I have at 
least ESV working on my mobile. Unfortunately, I don’t seem to 
be able to open (both on the phone as well as in 1.1 simulator) 
any Czech bible (tried CzeBKR and CzeCEP).

ESV works in my Peak, but in the 1.1 simulator, I get these 
errors when installing it:

TypeError: i is undefined app.js:209
Error in parsing value for 'width'.  Declaration dropped.  index.html
"http://www.crosswire.org/sword/servlet/SwordMod.Verify?modName=ESV&main=true&pkgType=raw" app.js:224
GET http://www.crosswire.org/sword/servlet/SwordMod.Verify [HTTP/1.1 200 OK 421ms]
Error in parsing value for 'right'.  Declaration dropped.  index.html
Error in parsing value for 'bottom'.  Declaration dropped.  index.html
UnknownError app.js:204

When trying CzeCEP in 1.2 simulator I get the same error 
(Unknown Error in app.js:204). In both cases also [objectEvent] 
jumps up. No idea, what it is.

Also I got with ESV in 1.2 this error:

TypeError: this.currentModule.getVersesInChapter is not 
a function app.js:221

Also, when trying to install CzeCEP in 1.2 I get it installed, 
but it never finishes when trying to display Mat 1.1 and I get 
an error

TypeError: i is undefined app.js:209

I wonder whether these errors are influenced by the order of 
installation of modules.

>Did you get any messages in the console? I could install your 
>module without errors.

I haven’t figured out how to connect old version of FF Simulator 
(which I need for 1.1) to the running app.

With 1.2 see above.



http://www.ceplovi.cz/matej/, Jabber: mcepl<at>ceplovi.cz
GPG Finger: 89EF 4BC6 288A BF43 1BAB  25C3 E09F EF25 D964 84AC
Roses are red;
    Violets are blue.
I'm schizophrenic,
    And so am I.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 190 bytes
Desc: not available
URL: <http://www.crosswire.org/pipermail/sword-devel/attachments/20131227/dca9f878/attachment.sig>

More information about the sword-devel mailing list