Er, that was the new line. > if ((size > 0) && cacheBuf && ((unsigned)start < cacheBufSize)) { > //TODO: optimize this, remove strlen The old line was: if ((size > 0) && cacheBuf && ((unsigned)start < strlen(cacheBuf)) { //TODO: optimize this, remove strlen