[sword-devel] Corba-bindings of sword

Peter von Kaehne refdoc at gmx.net
Tue Aug 19 09:28:18 MST 2008

Ok, I have a new installation done this time outside of ROOT, but a separate webapp swordweb, with the  swrodweb/src classes residing in a directory src next to it and the sword/bindings clsses copied into swordweb/WEB-INF/classes.

Now I am back to my original Nullpointer exception. All classes are found, but nothing works.

I had installed two Farsi bibles and one English, the ESV and have changed swordweb/WEB-INF/crosswire.properties accordingly. it reads



-------- Original-Nachricht --------
> Datum: Tue, 19 Aug 2008 16:22:49 +0200
> Von: "Peter von Kaehne" <refdoc at gmx.net>
> An: SWORD Developers\' Collaboration Forum <sword-devel at crosswire.org>
> Betreff: Re: [sword-devel] Corba-bindings of sword

> > I don't think it's a class problem.  It would have given you a 'class 
> > not found' error.
> That is exactly what I am getting right now. Maybe I destroyed someting
> more, I do not know. I feel at the moment utterly frustrated by my lack of
> knowledge. I do not know what i am doing wrong.
> I have a directory /usr/share/tomcat5/webapps/ROOT. I emptied the demo
> pages out of there and dumped into that the content of swordweb/webapps
> I copied the two sets of class libraries (from swordweb/src and from
> sword/corba/bindings (in their shell of directories org/crosswire/sword/util) 
> etc into /usr/share/tomcat5/ROOT/WEB-INF/classes/
> I also tried copying these two sets of class libraries into
> /usr/share/tomcat5/ROOT/classes and I tried all kinds of variations on both of this. I
> never get beyond that  swordorb and util is not found. Never.
> Peter
> org.apache.jasper.JasperException: Unable to compile class for JSP
> Generated servlet error:
> /var/lib/tomcat5/work/Catalina/localhost/_/org/apache/jsp/index_jsp.java:6:
> package org.crosswire.util does not exist
> import org.crosswire.util.Base64;
>                           ^
> Generated servlet error:
> /var/lib/tomcat5/work/Catalina/localhost/_/org/apache/jsp/index_jsp.java:13:
> package org.crosswire.sword.orb does not exist
> import org.crosswire.sword.orb.*;
> ^
> etc. 16 symbols not found
> -- 
> Psssst! Schon das coole Video vom GMX MultiMessenger gesehen?
> Der Eine für Alle: http://www.gmx.net/de/go/messenger03
> _______________________________________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel
> Instructions to unsubscribe/change your settings at above page

Ist Ihr Browser Vista-kompatibel? Jetzt die neuesten 
Browser-Versionen downloaden: http://www.gmx.net/de/go/browser

More information about the sword-devel mailing list