[sword-devel] Corba-bindings of sword

Peter von Kaehne refdoc at gmx.net
Tue Aug 19 07:22:49 MST 2008

> I don't think it's a class problem.  It would have given you a 'class 
> not found' error.

That is exactly what I am getting right now. Maybe I destroyed someting more, I do not know. I feel at the moment utterly frustrated by my lack of knowledge. I do not know what i am doing wrong.

I have a directory /usr/share/tomcat5/webapps/ROOT. I emptied the demo pages out of there and dumped into that the content of swordweb/webapps

I copied the two sets of class libraries (from swordweb/src and from sword/corba/bindings (in their shell of directories org/crosswire/sword/util)  etc into /usr/share/tomcat5/ROOT/WEB-INF/classes/

I also tried copying these two sets of class libraries into /usr/share/tomcat5/ROOT/classes and I tried all kinds of variations on both of this. I never get beyond that  swordorb and util is not found. Never.


org.apache.jasper.JasperException: Unable to compile class for JSP

Generated servlet error:
/var/lib/tomcat5/work/Catalina/localhost/_/org/apache/jsp/index_jsp.java:6: package org.crosswire.util does not exist
import org.crosswire.util.Base64;

Generated servlet error:
/var/lib/tomcat5/work/Catalina/localhost/_/org/apache/jsp/index_jsp.java:13: package org.crosswire.sword.orb does not exist
import org.crosswire.sword.orb.*;

etc. 16 symbols not found
Psssst! Schon das coole Video vom GMX MultiMessenger gesehen?
Der Eine für Alle: http://www.gmx.net/de/go/messenger03

More information about the sword-devel mailing list