[sword-devel] Corba-bindings of sword

Jonathan Morgan jonmmorgan at gmail.com
Thu Aug 14 07:11:13 MST 2008

On Fri, Aug 15, 2008 at 12:03 AM, Peter von Kaehne <refdoc at gmx.net> wrote:
> Thanks to everyone - this worked.
> Now the next problem.
> Making /sword/bindings/corba/java fails with 12 exceptions which look like the following:
> src/org/crosswire/sword/orb/SwordOrb.java:214: cannot resolve symbol
> symbol  : class HttpServletRequest
> location: class org.crosswire.sword.orb.SwordOrb
>        public static SWMgr getSWMgrInstance(HttpServletRequest request) throws Exception {
>                                 ^
> src/org/crosswire/sword/orb/SwordOrb.java:185: cannot resolve symbol
> symbol  : class HttpSession
> location: class org.crosswire.sword.orb.SwordOrb
>                HttpSession session = request.getSession();
>                ^
> I have java 1.4 SDK from the Ubuntu repositories.

I ran into similar problems a few days ago on a different project.
All of those classes are servlet style classes, from the Java servlet
API (javax.servlet.*).  These are not ever shipped with the Java SDK,
AFAIK.  If you want to get them, I think you need to add the
servlet-api.jar file from a servlet container (if going that route, I
would tend to use Tomcat, but Jetty is another good option).

Hope that helps.


More information about the sword-devel mailing list