[sword-devel] osis

DM Smith dmsmith555 at yahoo.com
Sat Dec 3 21:04:36 MST 2005

Lalremlien Neitham wrote:

> Hello All,
> I am back again with one step taken. I created an OSIS XML file. And 
> it works ok. Now the next part is - how do i make new lines for 
> verses? I tried it with HTML's <br> but its not working :-))

OSIS does not have line breaks per se. There is a "line break" <lb/> 
empty element that is allowed in a "line group" <lg> element. This is 
use to mark up poetic material. There is also a paragraph <p> element 
that marks up paragraphs. Please be aware that how OSIS is rendered is 
up to the application. A paragraph will cause a line break, but it may 
also create a blank line.

Unlike HTML, these cannot be used anywhere, but only where the 
dtd/schema allows. Also, if you use <p> you need a </p>, because every 
begin tag needs an end tag. (If OSIS had a "br" element you would need 
to type it as <br/>)

> I also found some problems in regards to some special characters in my 
> language, such as:
> â (Alt + 0226)
> ê (Alt + 0234)
> î (Alt + 0238)
> ô (Alt + 0244)
> û (Alt + 0251)

Your keying needs to result in either UTF-8 or MS Window's Latin-1 (i.e. 
cp1252). You can use one or ther other, but not both.

> When any of them are inserted in the <verse></verse> or parts of the 
> osis document, the verses are not shown from thence. Is there any way 
> to solve these problem? Or this is NOT an OSIS problem? But the 
> backend coding problem of the website (php)?

I think this is a problem with your editor. There are various conversion 
utilities that can convert from one encoding to another. So it may be 
possible to continue to create the file as you are and recode it later.

> I hope someone can suggest me another informative ways to solve the 
> problem I am going through.
> Hmm, BTW, I tried to install the Sword modules I downloaded, but I am 
> not able to install them as they said, ICU....dll missing. Anybody can 
> tell me where I can download sword dlls? I downloaded the sword...zip 
> modules on the suggested site, but that is not the notified missing file.

You can find icu in the same directory as the other utilities. (See my 
last reply.)

Hope this helps,

More information about the sword-devel mailing list