mvnForum Homepage

Print at Oct 17, 2017 1:28:44 PM
Posts: 25   Pages: 3   [ Previous Page | 1 2 3 ]
View all posts in this thread on one page
Posted by mdbergmann at Jan 17, 2010 2:09:52 PM
Re: MacSword 2.0.7 - Unable to install modules
Hmm, well.
So the module installer in MacSword 1 does work?
If so you could use that to install the modules and then can use MacSword 1 or 2 as you like.

Problem is, as long as it does work in my environment I unfortunately can't find any bug there might be.


Posted by tbob32 at Jan 17, 2010 10:21:39 PM
Re: MacSword 2.0.7 - Unable to install modules
The dir I created was from the following section of the Readme.rtf in the docs folder in the dmg download, as follows:
Manually installing modules
The download of MacSword application does not include any modules (bibles, dictionaries, etc.). You need to download them manually from the Crosswire website. For MacSword special modules (.swd) are available which have to be placed into the folder (if the folder does not exist, please create it first):
/Users/<username>/Library/Application Support/Sword
In MacSword under Preferences->Module you need to point the Modules location folder to be the folder mentioned above and then restart. For MacSword version 1.3.1b2 and above this location is preset and it does not need to be changed. Just place your downloaded modules in the above mentioned folder.
MacSword 2 does not have this setting in preferences. This path is the only pre-defined module path in MacSword 2.

If I delete the dir and run the module installer it does create the dir and subfolders, appears to be downloading the KJV but nothing is installed. As mentioned before if I manually download the KJV and place it in that dir the app crashes on startup.


Posted by tbob32 at Jan 17, 2010 10:37:34 PM
Re: MacSword 2.0.7 - Unable to install modules
Ignore all of that, I just deleted all, rebooted, and reinstalled from fresh download. Tried the manual download and install again and it worked with two versions (KJV and MKJV). The app will start and work now. Since getting that working the module installer is now working.

Nothing I didn't try the other day, not sure what has happened or is different but all is now working. smile

Thanks for the help, let me know if there is something I can check that may help you debug,

Bob Taylor

Posted by iammikeb at Jan 18, 2010 8:42:58 AM
Re: MacSword 2.0.7 - Unable to install modules

Thanks for the tip. Worked like a charm.

I deleted every trace of MacSword from my previous installations. There were files in several directories to be deleted. I then rebooted and reinstalled and now the Module Installer is working just fine. Thanks a million Bob.


Might want to suggest to users that are upgrading from 1.x to do a complete uninstall (including deleting all previous files and directories) before upgrading.

Thanks again for the work that you put into this Manfred!

Posted by mdbergmann at Jan 19, 2010 1:30:28 AM
Re: MacSword 2.0.7 - Unable to install modules
I didn't suggest this officially because there is only a few people that have problems with old MacSword 1 files.
If at all it is not necessary to delete the MacSword.plist file in Preferences and the bookmarks.plist file in AppSupport/MacSword.
Or at least copy your bookmarks and put them back in later if you don't want to loose them.
I suggested at some point because of those problems to delete the whole Sword folder content in AppSupport because the problem of the crash and possibly of the module installer are SWORD related. And the Sword AppSupport folder is the only place where any files are SWORD related.


Posts: 25   Pages: 3   [ Previous Page | 1 2 3 ]