mvnForum Homepage

Print at Oct 23, 2017 12:07:22 PM View all posts in this thread on one page
Posted by dleehend at Mar 13, 2004 3:19:55 PM
BibleTime shuts down
I am using Bibletime 1.4.1 from the Debian package.
Everything was working great in 1.4
I did an upgrade on two different machines and am having the same problem.
I can open Bibletime and run either the Bibletime or Sword configure screens, but as soon as I select a module to open Bibletime just shuts down.

This is the error I get when I run it from the terminal:
bibletime: relocation error: bibletime: undefined symbol: _ZN3DOM4NodeC1Ev

I get the same error from any module I try to open.
I have checked and my modules are in the same place they were. I also tried upgrading some of the older modules I have using the Sword config screen, but that did not help either.

Any ideas would be appreciated.

Posted by peterthevicar at Mar 13, 2004 4:01:42 PM
Re: BibleTime shuts down
I get this too. It seems to be when I upgraded to KDE 3.2 which is quite a major new KDE version. I think bibletime is using some deprecated calls which 3.2 has now stopped supporting. You can go back to 3.1 using sources for sarge or wait for a fix (or fix it if you're a lot cleverer than me!)

HTH, Peter

Posted by jansorg at Mar 14, 2004 4:28:40 AM
Re: BibleTime shuts down

ts just needs a recompile on the new KDE 3.2.
KDE 3.2 isn't binary compatible in the (not public API) functions BibleTime uses in the KHTML library.

We hope to provide new binary packages soon,

Posted by dhcolesj at Mar 21, 2004 12:51:31 PM
cool   Re: BibleTime shuts down
I downloaded the source and compiled it and it would not load at all.
I've been using Bible time since 1.1, and love it alot. So I guess I'll have to wait.
I'm using KDE 3.2.1, XFree86 4.3 and Kernel 2.4.25, (mainly a sarge setup that's been upgraded to sid). But, it never has worked on this machine. I can get by with Gnomesword2 which works fairly well, just a different interface.

If you have any hints on the compile that would help I'd appreciate it. I just basically did a "./configure --prefix=/usr" then "make" then "make install". I did get an error about libcurl not being greater than 7.9 but this version of debian runs libcurl2 which is only at 7.11. it did compile after I installed the libcurl2-dev package, but when I tried to run bibletime it just segfaulted.

Posted by jansorg at Mar 28, 2004 4:12:36 AM
Re: BibleTime shuts down
this seems to be the fault of Sword. It was compiled with curl 7.10 and no tries to load 7.11, which doesn't work. And sadly Sword doesn't compile with that curl atm.

So the solution probably is to compile Sword with --without-curl and then BT.
I'm sorry that this will disable the module downloading. I'm sorry for all these troubles,


Posted by dhcolesj at Mar 29, 2004 6:15:46 PM
Re: BibleTime shuts down
No Problem. I'm having other issues with this build on my laptop, so I"ll probably be reloading anyway. You guys are doing a good work, thanks!

Posted by dhcolesj at Mar 31, 2004 11:05:25 PM
biggrin   Re: BibleTime shuts down
cool I just did an update on my Laptop before I rebuilt it to see if any of the latest gadgets had somehow gotten better, and they did. BibleTime runs now! Way cool. Now to just get my touchpad to work