mvnForum Homepage

Print at Oct 24, 2016 9:03:51 AM View all posts in this thread on one page
Posted by puddleDuck at Jun 22, 2004 3:43:25 AM
Continued installation problems with SuSE 8.0

Joachim provided a useful solution for my previous compile problem (thanks Joachim), but then yet another issue halted compilation. I thought it might be more appropriate to start a new thread with this new error:

/usr/include/g++/stl_pair.h:44: incompatible types in assignment of `const char[10]' to `char[10]'
make[4]: *** [btinstallmgr.o] Error 1
make[4]: Leaving directory `/usr/local/bibletime-1.4.1/bibletime/frontend'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/usr/local/bibletime-1.4.1/bibletime/frontend'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/local/bibletime-1.4.1/bibletime'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/bibletime-1.4.1'
make: *** [all] Error 2

I googled the first line and this led me to, which is a discussion that is just a little out of reach for me, although I did get the sense that it may be helpful for me to compile stl from to see if this helps.

Will compiling stl from the source mentioned potentially break anything else? Any further suggestions?

Thanks & Best Regards,

Posted by jansorg at Jun 23, 2004 2:14:18 AM
Re: Continued installation problems with SuSE 8.0
that's another bug which is not fixed in 1.4.1.

A user reported that the following changes help>
< config["Sources"].insert( std::make_pair("FTPSource", is->getConfEnt()) );
> config["Sources"].insert( std::make_pair((const SWBuf)"FTPSource", is->getConfEnt()) );
< config["Sources"].insert( std::make_pair("DIRSource", is->getConfEnt()) );
> config["Sources"].insert( std::make_pair((const SWBuf)"DIRSource", is->getConfEnt()) );

The stuff behind < is the old, change it to the stuff behind >. The file to be changed is frontend/btinstallmgr.cpp.

This will be fixed in the next version.

I hope that helps,

Posted by puddleDuck at Jun 24, 2004 6:40:46 AM
Re: Continued installation problems with SuSE 8.0
Thanks again worked fine. I just had to make a soft link to point to the curl library and compilation succeeded.

Now that it is compiled & installed, I need to figure out how to make it play nicely with curl. Upon execution it bails out with the following:

steve@faraday:~> bibletime
bibletime: error while loading shared libraries: cannot open shared object file: No such file or directory

...but as far as I can tell, no such file is associated with a curl installation:

faraday:/usr/local/curl-7.12.0 # find / -name
faraday:/usr/local/curl-7.12.0 #

However, with this version of curl, I do find the following:

faraday:/usr/local/curl-7.12.0 # find / -name libcurl*
---[snip some stuff]---
---[snip the rest]---

The top line is the link to the library I made to enable compilation. I took a guess and linked the others as well, but bibletime demands the *.so.2 version. I am now guessing that this means that I actually need curl to be <= 7.12.0 as well. Am I correct?

Thanks & Best Regards,

Posted by puddleDuck at Jun 24, 2004 9:04:10 AM
Re: Continued installation problems with SuSE 8.0
Hello again,

I tried curl 7.10.8 and it works fine. It seems however that this would not be the intended behavior as INSTALL simply says >=7.10. Maybe this is a bug too?

Thanks again for all your assistance Joachim.

Best Regards,