mvnForum Homepage

Print at Oct 20, 2017 9:51:41 PM View all posts in this thread on one page
Posted by justahuman at May 8, 2011 5:19:22 AM
search index created bibles
Hi, I got some self made bundels for sword. I created a new ftp source and downloaded the bibles, but where must I put the search index because(is a normal search index enough?)?

Posted by niccarter at May 8, 2011 4:21:29 PM
Re: search index created bibles
Hi there,

If you bundle the search index in the normal place inside the module's ZIP file, it will be automatically installed if you install the module using the Module Maintainer Mode method. I haven't tested what happens if you install it as a new ftp source.

I hope that helps?

Nic... :)
PocketSword Developer

Posted by justahuman at May 10, 2011 7:33:11 AM
Re: search index created bibles
fixed, i added the search index and downloaded the bible again now i can search.

Posted by mdbergmann at May 11, 2011 11:37:32 PM
Re: search index created bibles
MacSword or now Eloquent can create a CLucene index which can be used for PocketSword. In fact this feature was added specifically for this use case.
In the left sidebar right-click on a module you want to create the index for. In the context-menu you will see the menu item "create clucene search index".
The index will be written to a "data" folder within the module's data.


Posted by at Oct 6, 2012 3:21:28 PM
sad   Re: search index created bibles
I use xiphos for windows to create a search index. Then I put the lucene-directory with its files in the zip-file of the bible-modul (plaintext). After installing the module using the MMM method, search still doesn't work. what's wrong? does the index created with xiphos not work? the loaded bible modul works fine.

i use iPhone 4 with iOS6.

Posted by karl at Oct 6, 2012 8:51:56 PM
Re: search index created bibles
Xiphos-created index files work just fine in PocketSword; I do this with a number of my own modules.

You need to make sure that the entire module area including the lucene subdirectory is part of what goes into the *.zip. Alternatively, if you are installing via a repo, again make sure that the lucene subdirectory is present alongside the ot* and nt* files.
Project Admin, Xiphos

Posted by at Oct 7, 2012 3:05:42 PM
sad   Re: search index created bibles
Unfortunately it still doesn't work. The modules work fine but if click to search the message "Sie haben für dieses Modul keinen Suchindex installiert" (no search index).

The structure in my zip-file is

     --gerlut1545  -> nt.bzs, nt.bzv, ...
        --lucene -> _0.cfs, segments.gen, segments2

can I send you the zipfile for testing?

Posted by vtcuong at Nov 7, 2012 3:24:17 AM
Re: search index created bibles
I have the same problem. I am using Xiphos to install my own Bible Module into Xiphos. Then i have created index for this mudule. Finally, i archive my Module. I have used the archived Module to upload PocketSword on my iphone. The Bible works well but the search index doesnt work. May you help me to get fixed this issue.

Posted by at Nov 7, 2012 4:35:04 AM
Re: search index created bibles
install an older version of xiphos

Posted by vtcuong at Nov 7, 2012 9:01:04 AM
Re: search index created bibles
Thanks for your hint. I have removed Xiphos 3.1.5 and installed the Xiphos 3.1.4. The created search index works perfectly on iphone 4S.