mvnForum Homepage

Print at Sep 24, 2017 1:51:24 AM View all posts in this thread on one page
Posted by jawaibel at Dec 28, 2010 11:44:45 AM
Preferences Won't Save
Just installed the latest update and the preferences won't save. If I close out of Macsword and re-open it, the background color and other preferences are back to default. I have saved a new default session, but this doesn't save the preferences. I mostly want the background color to be white, but each time I open the program I have to go in and change the preferences again. Any idea why this is? Thanks!

P.S. I am on a Mac OS 10.5.8 with Macsword 2.2.12-1776

Posted by mdbergmann at Dec 28, 2010 12:03:36 PM
Re: Preferences Won't Save

Strange. It works here with the same version.
Try trashing your prefs file in Preferences (org.crosswire.MacSword.plist)


Posted by jawaibel at Dec 28, 2010 12:46:55 PM
Re: Preferences Won't Save
That didn't work. Instead a warning came up that said:

"A Macsword 1 module has been detected. This can cause a crash with Macsword 2. Do you want me to delete the database? etc..."

I tried going ahead with this and it deleted the databases (removing all the modules), but the preferences still don't save. Now each time I open Macsword I get that same warning. Should I just delete the app and reinstall? If so what all should I delete? Thanks.


Posted by mdbergmann at Dec 28, 2010 3:55:51 PM
Re: Preferences Won't Save
Weird. After you deleted and restart MacSword, is there a new prefs file created?
This requester should only come up once if there is no prefs file. Seems the prefs file can't even be created.
Maybe a permission problem. Is your home folder on a network share?


Posted by jawaibel at Dec 30, 2010 1:31:24 PM
Re: Preferences Won't Save
I agree. The prefs file is not being created. I tried repairing permissions in disk utility and that didn't seem to have any effect. My home folder is not on a shared network. I have completely deleted macsword and reinstalled and I still get the same warning as before. Any ideas why this keeps happening?

I feel like there is some magic setting that I just need to turn on/off and it will work, but I don't know what it is. Thanks.


Posted by mdbergmann at Dec 31, 2010 3:12:37 AM
Re: Preferences Won't Save
Can you create files/folders in Preferences with Finder?


Posted by jawaibel at Jan 6, 2011 6:40:00 AM
Re: Preferences Won't Save
Yes, I can place a folder in the preference file, but I had to authenticate that I was the administrator first. I think I mentioned previously that I tried running Repair Permissions from Disk Utility and that finds some problems, but doesn't fix them. Is it possible my entire preferences file is corrupt somehow? Is it ok to just trash the whole preferences file and let the computer rebuild it or does that mess things up even worse?

Thanks for your help.

Posted by mdbergmann at Jan 6, 2011 11:54:17 AM
Re: Preferences Won't Save
There is definitely something wrong if you have to authenticate in order to create a file or folder in your own preferences place.
I wouldn't delete all prefs but you could try to change the permissions of the preferences folder and all prefs files recursively.
If you do "Get info" on the Preferences folder and check the permissions you should be the owner and group of this folder.
Owner and group should have read, write and execute rights.
If this is not the case you should apply those permissions to Preferences folder and all subitems.