mvnForum Homepage

Posted by tcrawfordjakarta at Jun 1, 2011 7:47:41 AM
Compiling sword on Fedora 15
I am trying to compile sword svn 2625 on Fedora 15, the compile quits with the following:

/bin/sh ../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I../include -I../include -I/usr/include -DUSE_AUTOTOOLS -DUNIX -Dunix -D__unix__ -DSWICU_DATA=\"/usr/lib/sword/1.6.2_icu_4.4.2\" -D_FTPLIB_NO_COMPAT -g3 -O0 -Wall -Werror -D_ICU_ -ftemplate-depth-25 -DCURLAVAILABLE -I/usr/include -I/usr/lib -DUSELUCENE -MT url.lo -MD -MP -MF .deps/url.Tpo -c -o url.lo `test -f '../src/utilfuns/url.cpp' || echo './'`../src/utilfuns/url.cpp
libtool: compile: g++ -DHAVE_CONFIG_H -I. -I../include -I../include -I/usr/include -DUSE_AUTOTOOLS -DUNIX -Dunix -D__unix__ -DSWICU_DATA=\"/usr/lib/sword/1.6.2_icu_4.4.2\" -D_FTPLIB_NO_COMPAT -g3 -O0 -Wall -Werror -D_ICU_ -ftemplate-depth-25 -DCURLAVAILABLE -I/usr/include -I/usr/lib -DUSELUCENE -MT url.lo -MD -MP -MF .deps/url.Tpo -c ../src/utilfuns/url.cpp -o url.o
../src/utilfuns/url.cpp: In member function 'void sword::URL::parse()':
../src/utilfuns/url.cpp:136:7: error: variable 'checkAnchor' set but not used [-Werror=unused-but-set-variable]

Can I get some help with this?

I tried compiling the tar ball sword-1.6.2 and I get the same error.

Tom Crawford