mvnForum Homepage

Posted by mdbergmann at Aug 21, 2009 12:24:57 PM
Re: MacSword 2 beta announcement

For me, MacSword 1 opens the Modules in /Applications/MacSword/Modules (MacSword 1 is at "/Applications/MacSword/MacSword" since I downloaded MacSword 2β as

Ok, you have set this as the module path in MacSword preferences.

I don't remember doing that; is it possible that this preference was the default some time?

For old MacSword versions before 1.3 the default module path was "./Modules".
Since MacSword 1.4 it is the one in Application Support.

MacSword 2 has a fix path which is the one in "Application Support".
The reason for this is that we agreed to this path as other applications like BibleDesktop and BibleTime also use this path for module lookup.

That sounds reasonable. I haven't tried BibleDesktop and BibleTime – do they also use .swd files, or just the standard unix directory structure? Then it might be a sensible choice to declare .swd deprecated?

AFAIK MacSword is the only application supporting .swd files. They are not deprecated.

I'm using .swd modules, too and this is working. The only thing I can imagine is that it is a module that is causing the crash when MacSword is trying to load it.
So we need to find out in your case which one it is.

It certainly is not a single module. I've just redownloaded the .swd file for KJV and unpacked it freshly to ~/Library/Application Support/Sword – and the programme crashed; sorry. Should I try one of the modules that work for you?

I have lots of modules installed including the KJV.

Your environment is still not clear to me:
- did you try starting with a fresh "Application Support/Sword" folder?
- do you only have the KJV module as .swd file in this folder?
- did you try installing the module using the module installer?

I just tried to move away my "Sword" folder, started MacSword so that it created this folder. Then quit MacSword, copied the KJV.swd into this folder and start again. All worked.

Can you give me a similar sequence of actions you did that are re-producable for me which lead to a crash?