[xiphos-devel] Xiphos unusable on Archlinux

Caleb Maclennan caleb at alerque.com
Mon Jul 10 02:40:39 MST 2017

Yvand are you running the xiphos, xiphos-git, or xiphos-gtk3 package 
from the AUR? Have you tried one of the other packages?

I can confirh that xiphos-gtk3-4.0.4-1 as of the last time I compiled it 
was pretty non-functional, but I seem to recal the 2 version (which is 
what you should get on the base package) working fine.


yvand wrote:
>Hi all,
>Since several months, Xiphos is completely broken and unusable on 
>ArchLinux. My archlinux is uptodate and sword+xiphos comes from AUR 
>(sword-svn and xiphos-git packages).
>Indeed Xiphos is unusable, because :
>- when I select a chapter, it is EXTREMELY slow (except in the 
>parallel view)
>- notes does not work (nothing in preview pane)
>- left pane broken : impossible to select a bible/commentary in the 
>left panel (click on items does not work !) + buttons "Modules", 
>"Search"… does not work (nothing happens)
>Here is a screencast : https://yapper.fr/~yvand/xiphos-frejnd.ogv
>Why Xiphos is so buggy on my system ? I tried both Xorg and Wayland in 
>GDM but none works fine.
>xiphos-devel mailing list
>xiphos-devel at crosswire.org

More information about the xiphos-devel mailing list