[sword-devel] What is the lowest version of iOS to be currently supported in PocketSword?

Manfred Bergmann manfred.bergmann at me.com
Wed Sep 21 11:44:38 MST 2016

Hi Tim.

I thought actually I had updated libcurl (build for 64bit and latest versions).
Also I had updated MBProgressHUD to the latest version.
I can’t remember for which OS version libcurl was build.

I would not go back to 5.1 with compatibility as overall this means a higher work on maintenance.
And you can’t use any new features of the OS.

For anyone still using iOS 5.1 the current PocketSword app should still work?


> Am 20.09.2016 um 22:59 schrieb TS <outofthecube at icloud.com>:
> I've been going through the code and making fixes, and in the process XCode has warned me that libcurl is for version iOS 6 and higher and also I've discovered that MBProgressHUD was also written for iOS 6 and higher. It seems that the external frameworks were updated from the previous release of PocketSword. So, is the lowest version supported iOS 6 now? or is it still 5.1.1 and I can ignore the warnings? If 5.1.1 should still be supported, do all of the newer frameworks still work with this version of the iOS or does compatibility need to be tested between iOS ver. 5.1.1 and the newer frameworks (and workarounds be implemented if need be)?
> - Timothy
> _______________________________________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel
> Instructions to unsubscribe/change your settings at above page

More information about the sword-devel mailing list