[sword-devel] CrossWire subversion server error

John Austin gpl.programs.info at gmail.com
Sun Nov 8 05:13:31 MST 2015

Thanks all,
Git on crosswire.org works fine. Subversion still isn't working 
(returning the same error). When using a VPN, there is no problem at all.

Subversion fails on all computers I've tried, even without any proxy or 
firewall. Ping to crosswire.org ( works fine, but then svn 
still fails after the timeout. I have tried two different local ISPs and 
get the same message:

svn: E000110: Error running context: Connection timed out

I have not noticed any Great-Firewall issues recently (which indeed 
sometimes are noticeable). All other software services here have been 
working without a glitch. I can access Subversion on googlecode just 
fine. Also since it seems that crosswire.org security was recently 
updated, this all leads me question the server(?)

Might it help if I send ISP info? Or even exact IPs to scan log files for?

We're using virtual machines for almost everything these days and 
provisioning them with a VPN is slow, so it's not an ideal solution, but 
it does work for now.

Thank again!

On 11/06/2015 08:49 PM, Troy A. Griffitts wrote:
> Dear John,
> I am sorry for not responding sooner. I have no idea what might be the
> problem. We do have some IP bans on the server but they are for all
> ports. And thinking of it, that SVN command should be using the same
> port as your web browser. It seems a very odd problem that your browser
> can get through but not that SVN command. Do you have any kind of proxy
> running that might either be interfering with the SVN command or helping
> the web browser?
> Troy
> On November 5, 2015 11:27:44 PM MST, John Austin <gpl.programs.info
> <http://gpl.programs.info>@gmail.com> wrote:
>     Something has changed so that for the past week now, the CrossWire
>     subversion server has been unreachable from Central Asia.
>     This:
>     svn checkouthttp://crosswire.org/svn/sword/trunk  ./
>     Only returns this (after a time-out wait):
>     svn: E000110: Error running context: Connection timed out
>     Access tohttp://crosswire.org/svn/sword/trunk  through a web-browser
>     works fine. But svn isn't working.
>     Does anyone know what is wrong?
>     -john
>     ------------------------------------------------------------------------
>     sword-devel mailing list: sword-devel at crosswire.org
>     http://www.crosswire.org/mailman/listinfo/sword-devel
>     Instructions to unsubscribe/change your settings at above page
> --
> Sent from my Android device with K-9 Mail. Please excuse my brevity.

More information about the sword-devel mailing list