[sword-devel] Building Python binding to Sword on Windows returns exit code 1

Ben Morgan benpmorgan at gmail.com
Wed May 28 20:48:01 MST 2014

This probably doesn't directly help your issues here, but the SWIG 3.0
issue seems to have been fixed in SWIG 3.0.1 which was released yesterday.

   - A few notable regressions introduced in 3.0.0 have been fixed - in
   Lua, nested classes and parsing of operator <<.

As for this one here, I would try the sword_static, ignore the errors
building the samples, and copy the sword.lib like you found you had to.
That might work, but probably won't either.

Greg, is it possible the non-static one doesn't define SWUSINGDLL when
compiling the swig generated code? If I remember rightly, that causes
God Bless,
 For I have no pleasure in the death of anyone,
declares the Lord God; so turn, and live.”
Ezekiel 18:32 (ESV)

On Sat, May 17, 2014 at 11:36 AM, R Johnson <
ps16thypresenceisfullnessofjoy at gmail.com> wrote:

> I now have gotten closer to being able to do what I want, but still not
> quite there yet (sigh).
> I tried to build the 'libsword' solution without the 'sword_static'
> project, but then I actually got more errors than before. I have attached
> the output I got.
> I then tried building only the 'sword' project, which is (I think) the
> only project that must be built as a prerequisite to the 'swordswig'
> project. This worked OK without any errors.
> I then tried building the 'swordswig' project, which is of course
> necessary in order to build the Python bindings. Before doing so, I
> downgraded my version of SWIG to 2.0.12, so that I would not run into the
> SWIG 3.0.0 bug we discovered. The 'swordswig' build is getting farther now
> than it had before, but it still gives some errors. First it gave an error
> about not being able to open 'sword.lib'. Through a bit of experimenting, I
> found out that this was because it was looking for it in the 'sword-build'
> directory rather than its 'Release' subdirectory. I think this may be a bug
> that needs be fixed in the CMake file. I worked around it, however, by
> copying 'sword.lib' from the 'Release' subdirectory to the 'sword-build'
> directory. Since I did that, however, it is giving me other errors that I
> am not knowledgeable enough to solve. I have attached the output I got from
> building 'swordswig', first before I copied the 'sword.lib' file, and
> secondly afterwards. In the second build log, SWIG complains that there are
> 35 unresolved externals.
> Thank you again for your help.
> -- Timothy
> _______________________________________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel
> Instructions to unsubscribe/change your settings at above page
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.crosswire.org/pipermail/sword-devel/attachments/20140529/0d59f9a7/attachment.html>

More information about the sword-devel mailing list