[sword-devel] Installed on a Mac, OS X 10.9.2!

Shane Cooke shanecooke at mac.com
Mon Apr 7 10:32:31 MST 2014

Hello everyone.

Praise God, I have version 2893 of osis2mod installed and running on my late 2012 Retina Macbook Pro, 13”, OS X 10.9.2, 2.5 GHz Intel Core i5, 8 GB RAM! I can now generate modules right from my own Mac. 

I had been using a Sword installation on my Ubuntu 12.04 on a VM.  It wasn’t convenient to hop back and forth, using the soon to be discontinued Ubuntu One cloud storage to sync my source file on my Mac to the VM Ubuntu.

Well, I downloaded the source, and after the first run was notified I needed ICU. I decided to try to install ICU, despite previous apparent failures, by reading this blog:
http://themidnightprogrammer.blogspot.ca/2010/09/unicode-with-icu.html and he seemed to have done it,  it made me think, why not me? Part of his post noted <unicode/unistr.h> which was an error that also appeared when I first tried to install the Sword 1.7.2 engine  “../include/utf8transliterator.h:41:10: fatal error: 'unicode/unistr.h' file not found” and he solved it by installed the ICU library, something I had previously tried to do, but failed (for what reason, I can’t recall). I followed the steps at http://freddyduarte.com/2013/08/14/installing-the-icu-libraries-and-the-php-intl-extension-on-a-mac/, and what do you know, ICU installed. I ran the sword installation again and voila, it installed. With some trepidation I then tried using osis2mod on my XML files, but it didn’t work (I was still seeing a strange paragraph number misplacement).

Then I realized that my osis2mod was still symlinked to the utilities in the the Eloquent app folders! So I looked to see where the new Sword utilities were installed and it was /us/bin/osis2mod.

So, in case anyone has previously tried to use the latest Sword engine 1.7.2 utilities on their Mac and it didn’t install or work, give it another try. They are now! There must be something in the OS X 10.9.2 update which changed something for the better-I had previously tried installed while on 10.8.x, and the first 10.9 update)


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.crosswire.org/pipermail/sword-devel/attachments/20140407/6bbdb9da/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4136 bytes
Desc: not available
URL: <http://www.crosswire.org/pipermail/sword-devel/attachments/20140407/6bbdb9da/attachment.p7s>

More information about the sword-devel mailing list