[sword-devel] strongs lookup issue in Bibletime

Gary Holmlund gary.holmlund at gmail.com
Sun Jun 17 10:30:57 MST 2012

Actually this probably is a sword issue. I reported a bug (API-151) in 
April and this problem seems consistent with that bug. Any chance of 
getting some attention on API-151?

Gary Holmlund

On 06/16/2012 09:09 AM, Matthew Patenaude wrote:
> Hi guys,
> Something strange is going on. The search function for Bibletime 
> (latest in Ubuntu 12.04 repository) has more problems than just the 
> strong's search issue in the TR module.
> I opened it today and did a regular English search for "longsuffering" 
> (KJV module) and got New Testament locations only. Xiphos gives the 
> full search results, starting with a reference in Exodus 34:6, and its 
> searches all seem to be fine.
> I then tried other words. "bush" (I was going for the burning bush in 
> Exodus) and also got only New Testament references (to the burning 
> bush, in the Gospels). So I tried "Moses", and the first reference I 
> got was in Malachi!
> What's going on here? I would happy to do whatever to troubleshoot the 
> problem to help out, but I would think someone on the devel team for 
> Bibletime would like to get this one figured out...
> Matthew Patenaude
> Message: 1
>     Date: Fri, 15 Jun 2012 07:56:44 -0400
>     From: Matthew Patenaude <mnglfiddle at gmail.com
>     <mailto:mnglfiddle at gmail.com>>
>     To: sword-devel at crosswire.org <mailto:sword-devel at crosswire.org>
>     Subject: [sword-devel] strongs lookup issue in Bibletime
>     Message-ID:
>     <CAC3BBQBjb3WNEET=sLQxSpYu0QfUzS=qogUpBNB2fpjYBhwOdg at mail.gmail.com <mailto:qogUpBNB2fpjYBhwOdg at mail.gmail.com>>
>     Content-Type: text/plain; charset="utf-8"
>     Hey all,
>     I sent this out before, but as I first tried just before the
>     servers came
>     back on, and then right after, I'm not sure anyone actually saw
>     the message.
>     When running BibleTime, one of my favorite functions is to
>     right-click on a
>     word, and choose "Strong's Search". However, after a recent upgrade to
>     Ubuntu 12.04, and the accompanying version of BibleTime, the Strong's
>     Search function is no longer working with the TR module. It does
>     work for
>     other modules (KJV, for instance), but not for TR.
>     I have deleted indexes, re-created indexes, re-installed modules,
>     recreated
>     indexes using Xiphos instead of BibleTime... nothing has worked so
>     far. The
>     search box comes up like it normally would, as if the program
>     *thinks* it
>     did the search, but it is empty. No results.
>     Xiphos performs Lucene lemma searches on the same module without any
>     problem. However, I like the simplicity and convenience of BibleTime's
>     interface for this.
>     Does anyone have any idea why the TR module is not working (it
>     used to,
>     before my upgrade)? I downloaded the module fresh in BibleTime
>     after the
>     upgrade.
>     Does anyone have any idea how to trouble shoot my issue?
>     Thanks,
>     Matthew Patenaude

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.crosswire.org/pipermail/sword-devel/attachments/20120617/b25e42c1/attachment-0001.html>

More information about the sword-devel mailing list