[sword-devel] osis2mod very happily generates modules with no text visible

Matěj Cepl mcepl at redhat.com
Sun Dec 25 00:30:06 MST 2011


trying to create an official version of the Czech Study Translation 
(what used to be CzeKMS, but it is now severely outdated and 
incomplete). I have original source in their custom XML scheme and I 
have created XSLT stylesheet 
(http://mcepl.fedorapeople.org/tmp/CEP2OSIS.xsl) which generates OSIS 
file (http://mcepl.fedorapeople.org/tmp/bible.xml.gz 4MB). The OSIS file 
validates and when I run

osis2mod modules/texts/ztext/czecsp/ bible.xml -v German

(osis2mod: $Rev: 2562 $; without -v parameter osis2mod core dumps; 
judging by the backtrace on 
http://mcepl.fedorapeople.org/tmp/osis2mod-gdb-output.txt.gz I would 
assume some kind of endless loop happened).

However, when running with -v German, it ends up happily (with -d 1021 
it generates tons of logs but I don't see any errors there; 
http://mcepl.fedorapeople.org/tmp/osis2mod.log.gz 11.3MB). The problem 
is that however I tried (including with diatheke and lookup build from 
the same source as osis2mod) I don't see any text in the generated 
bibles (./diatheke -b CzeCSP -f plain -e UTF8 -k Jn 3:16 returns 
nothing; the ZIP file is http://matej.ceplovi.cz/cizi/CzeCSP.zip).

Anybody any ideas what's wrong?

Thanks in advance for any kicking in the right direction,


P.S.: Also what is the state of the support for av11n (including -v 
German) in AndBible and jSword?

More information about the sword-devel mailing list