[sword-devel] CLucene

Eeli Kaikkonen eekaikko at mail.student.oulu.fi
Sat Aug 5 22:59:03 MST 2006

On Sat, 5 Aug 2006, Joachim Ansorg wrote:

> Hi,
> several people reported that the CLucene support is broken.

I tried to compile Sword for some time ago on Debian unstable. CLucene
had some problem then. Now I tried again (after upgrading Debian) and
compilation worked for some reason, maybe CLucene had been updated.

Now the problem is that I don't know how to use clucene with sword. Any
pointers? I just like to test it, preferably with some simple command
like tool like diatheke.

> That's true. It is broken, because the file clucene-config.h is in
> $prefix/lib/CLucene, it can't be found by the other clucene files and break
> the compile process.

I don't quite understand. I find clucene-config.h only in

> The fix is to include $prefix/lib/ in the list of include dirs. But I'm not an
> expert with the autoconf stuff.

I'm not an expert either, but I think it would be automake and
Makefile.am. Well, they don't call it Autoh*** without a reason :)

	Eeli Kaikkonen (Mr.), Oulu, Finland
	e-mail: eekaikko at mailx.studentx.oulux.fix (with no x)

More information about the sword-devel mailing list