[sword-devel] Compile, Link errors on FC2, partial fix

Torrey Hoffman thoffman at arnor.net
Wed Jun 30 10:20:11 MST 2004

Hmm, found another config/compile error.  Lucene isn't detected (or
configured?) properly on Fedora Core 2.

On Terry's advice that I needed to enable shared libraries in sword to
fix my gnomesword problems, I started from scratch, unpacked and
configured sword-1.5.7, made the same fix as before (TRUE --> 1 for
curl_easy_setopt in installmgr.cpp) and then compiled.  The configure
command was:

./configure --enable-shared --enable-static

which worked fine, but make died with this:

g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../include -DUSE_AUTOTOOLS -DUNIX
-DGLOBCONFPATH=\"/usr/local/etc/sword .conf\" -g -O2 -ftemplate-depth-25
-DCURLAVAILABLE -DUSELUCENE -MT rawtext.lo -MD -MP -MF .deps/rawtext.Tp
o -c ../src/modules/texts/rawtext/rawtext.cpp  -fPIC -DPIC
../src/modules/texts/rawtext/rawtext.cpp:22:29: CLucene/CLucene.h: No
such file or directory



then I tried ./configure --enabled-shared --enable-static

and make completed.  make install after that put libsword.so.3.0.0 in
/usr/local/lib so I'm off to try installing CVS gnomesword next...


Torrey Hoffman
torrey.hoffman at myrio.com (work) / thoffman at arnor.net (home)		

More information about the sword-devel mailing list