[sword-devel] Problem checking out Sword from CVS - Fedora Core 2

Steven P. Ulrick ulrick2 at faith4miracle.org
Sat Aug 14 16:15:50 MST 2004

On Wed, 11 Aug 2004 05:17:55 -0500
"Steven P. Ulrick" <ulrick2 at faith4miracle.org> wrote:

> Hello, Everyone :)
> Sometime after I heard that Crosswire.org was being moved to a new
> server(s), I attempted to update Sword from CVS.  I was not terribly
> shocked that it wouldn't update.  I figured it had something to do
> with moving to a new server.  A few weeks later, I'm trying to
> checkout a fresh copy of Sword from CVS, and I am still unable to do
> it.
> The instructions that I used are located on the following page:
> http://www.crosswire.org/sword/develop/biblecs/cvs.jsp
> Here I quote the exact instructions that I attempted to use to
> checkout a fresh copy of Sword from CVS:
> Under Linux
> Anonymous CVS may be used to obtain the latest source by using the
> :pserver:anonymous at cvs.crosswire.org:/cvs/core
> with the passwd: anonymous
> module name: sword
> eg.
> $ export CVSROOT=:pserver:anonymous at cvs.crosswire.org:/cvs/core
> $ cvs login
> Password: anonymous
> $ cvs checkout sword
> Here is a step by step breakdown of what happens:
> 1. "export CVSROOT=:pserver:anonymous at cvs.crosswire.org:/cvs/core" -
> This works with no errors.
> 2. "cvs login" - This brings up the expected prompt:
> "Logging in to
> :pserver:anonymous at cvs.crosswire.org:2401/cvs/core/sword CVS
> password:" 3. enter the password "anonymous" - The result is
> "/cvs/core: no such repository"
> As you can imagine this is not the desired behaviour :)
> At this time, Sword from CVS is required to compile Bibletime for
> Linux.
>  This is the reason why I want to keep a current Sword installation on
> our machine.
> Thanks in advance for your help :)
> Steven P. Ulrick

Hello, Again :)
I made a mistake in my original post on this subject.  The line that
"Logging in to :pserver:anonymous at cvs.crosswire.org:2401/cvs/core/sword 
CVS password:"

should read:
"Logging in to :pserver:anonymous at cvs.crosswire.org:2401/cvs/core/
CVS password:"

I am still not able to checkout Sword from CVS.  I tried to find a way
to browse the CVS repository, to find out if perhaps something was wrong
in the instructions on Crosswire.org.  SInce I am still not able to get
Sword from CVS, your help is greatly appreciated :)

Steven P. Ulrick

More information about the sword-devel mailing list