[sword-devel] Problems building CVS of Sword

Steven P. Ulrick sword-devel@crosswire.org
Sat, 12 Oct 2002 19:29:35 -0500

Hello, everyone :)
I'm having problems building the CVS of Sword on Red Hat 8.0.  Like I've
mentioned in the past, I have been doing it successfully since I
installed Red Hat 8, but for the past week or so, I've had a lot of
problems.  The version that I got the following error message from is a
fresh one, from just a few hours ago.  I've tried getting fresh copies,
and I tried running ./autogen.sh, all to no avail.

So here is the error message:
/bin/sh ../../libtool --mode=link g++  -g -O2 -ftemplate-depth-25   -o
threaded_search  threaded_search.o -L../../lib -lsword  -lpthread -lz
g++ -g -O2 -ftemplate-depth-25 -o threaded_search threaded_search.o 
-L/home/steve/CVS/sword/lib /home/steve/CVS/sword/lib/.libs/libsword.a
-lpthread -lz
make[3]: Leaving directory `/home/steve/CVS/sword/examples/cmdline'
make[3]: Entering directory `/home/steve/CVS/sword/examples'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/home/steve/CVS/sword/examples'
make[2]: Leaving directory `/home/steve/CVS/sword/examples'
Making all in apps
make[2]: Entering directory `/home/steve/CVS/sword/apps'
Making all in console
make[3]: Entering directory `/home/steve/CVS/sword/apps/console'
Making all in diatheke
make[4]: Entering directory
source='diatheke.cpp' object='diatheke.o' libtool=no \
depfile='.deps/diatheke.Po' tmpdepfile='.deps/diatheke.TPo' \
depmode=gcc3 /bin/sh ../../../depcomp \
g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../include  -DUSBINARY 
-g -O2 -ftemplate-depth-25 -c -o diatheke.o `test -f 'diatheke.cpp' ||
echo './'`diatheke.cpp
In file included from diatheke.cpp:8:
corediatheke.h:39: type specifier omitted for parameter `ostream'
corediatheke.h:39: parse error before `*' token
make[4]: *** [diatheke.o] Error 1
make[4]: Leaving directory `/home/steve/CVS/sword/apps/console/diatheke'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/steve/CVS/sword/apps/console'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/steve/CVS/sword/apps'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/steve/CVS/sword'
make: *** [all] Error 2

Thanks for your help :)
Steven P. Ulrick