[sword-devel] Strange problem with SWMgr

Torsten Uhlmann sword-devel@crosswire.org
Mon, 27 Mar 2000 16:38:33 +0200

"Troy A. Griffitts" wrote:
> > I encounter a strange problem while initializing SWMgr (in the Load()
> > function when it loads the different modules and filters).
> >
> > When Modules are found in the mods.d dir I get a seg fault, when this
> > dir is empty, no problem. I copied locales.d into SWORD_PATH, localetest
> > works. It worked before the localization was implemented. I wonder if
> > there is some setting which I have to put into my conf files.
> >
> > Does somebody know whats wrong?
> Let me make sure I understand the scenerio...
> When modules are found in the mods.d directory:
> /usr/share/sword/mods.d/sometext.conf
> /usr/share/sword/mods.d/modules/texts/rawtext/sometext/
> ?? Is this correct?  You mean that when the module's data files exist
> under the mods.d/ directory there is a problem?
My path is /usr/local/share/sword but that's probably not the point.
I've set SWORD_PATH to point to /usr/local/share/sword and there I have
mods.d, modules and locales.d. If mods.d is empty everything works fine.
I didn't try to move the texts away.

If mods.d hold one conf file (I tried two different) BibleTime crashes.

This setting did not change over the past month. I don't know if new
modules hold now new tags that I need to include?

As it seems to work for Joachim there might be a problem on my side.

Thanks for your help!

> Are you using a combination of a mods.conf and a mods.d directory?
>         Sorry for the problems.  Hope we can fix things.
>                         -Troy.


best regards,
Torsten Uhlmann


Wise men still seek him.