[jsword-devel] Patch for checkstyle

DM Smith dmsmith555 at yahoo.com
Mon Aug 16 15:07:55 MST 2004


SERIALUID tag is a better idea.

Joe Walker wrote:
> Wow, thanks. I think that must be the biggest patch you've ever sent me!
> I've applied it all with one minor change - I added a SERIALUID: tag
> to all the hacked serial uids, so we can find them all again at a
> later date.
> Thanks,
> Joe.
> 
> On Mon, 16 Aug 2004 10:12:15 -0400, DM Smith <dmsmith555 at yahoo.com> wrote:
> 
>>The changes here are many but either fix bugs or improve readability and
>>hence maintenance.
>>
>>This patch does the following:
>>adds whitespace around operators
>>adds newline to end of file
>>adds serialVersionUID to serializable files (I used 1 and marked them as
>>a placeholder for the real value.)
>>fixed 3 bugs where strings were compared using ==
>>changed new Thread(...).start() to Thread t = new Thread(...); t.start()
>>removed redundant parentheses
>>Fixed a possible null pointer bug.
>>Changed "" + obj and "" + primitive to eliminate ""
>>I changed returns of arrays to return copies (fix of potential bug)
>>Changed some static final to all uppercase.
>>Made a few classes final.
>>Made member variables final in Exception classes.
>>Changed array declarations from int var[] to int[] var.
>>changed multiple var declarations to single. E.g.
>>     int left = 0, right = 0, height = 0;
>>to
>>     int left = 0;
>>     int right = 0;
>>     int height = 0;
>>Added a missing break to a switch statement (bug fix)
>>Added "test" into "incremental" in core.xml so now it is build,test,install.
>>Changed checkstyle build.xml to not throw an exception. (it needs basedir)
>>Changed checkstyle custom.xml
>>     reordered checks to match the checkstyle website
>>     put in all missing tests as comments
>>     commented version 3.4 tests
>>     Enabled more tests (Where the amount of complaints was very small)
>>Changed findbugs build.xml to build html rather than test.
>>*I did not change the website to include this new file*
>>*The old link will be dead*
>>In jsword-web/build.xml I put the tool target back to what it was.
>>
>>
>>_______________________________________________
>>jsword-devel mailing list
>>jsword-devel at crosswire.org
>>http://www.crosswire.org/mailman/listinfo/jsword-devel
>>
>>
>>
>>
> 
> _______________________________________________
> jsword-devel mailing list
> jsword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/jsword-devel
> 



More information about the jsword-devel mailing list